Stadia Maps, Inc. - Client Dashboard Outage – Incident details

Client Dashboard Outage

Resolved
Major outage
Started about 1 month agoLasted about 24 hours

Affected

Marketing Website

Operational from 10:05 AM to 5:34 PM, Partial outage from 5:34 PM to 9:30 PM, Operational from 9:30 PM to 10:01 AM

Client Dashboard

Major outage from 10:05 AM to 8:48 AM, Operational from 8:48 AM to 10:01 AM

Maps

Operational from 10:05 AM to 5:34 PM, Degraded performance from 5:34 PM to 9:30 PM, Operational from 9:30 PM to 10:01 AM

Map Styles

Operational from 10:05 AM to 5:34 PM, Degraded performance from 5:34 PM to 9:30 PM, Operational from 9:30 PM to 10:01 AM

Stamen Map Styles

Operational from 10:05 AM to 5:34 PM, Degraded performance from 5:34 PM to 9:30 PM, Operational from 9:30 PM to 10:01 AM

External Services

Updates
  • Resolved
    Resolved

    All services remain operational. This incident has been resolved.

  • Monitoring
    Monitoring

    As of 08:30 UTC, all services have been restored. Our vendor is continuing to implement fixes on their side, but we opted for a full recovery procedure to restore operations.

    Due to the complexity of the failure, database recovery procedures were required, and approximately 24 hours of usage data were lost.

    We will continue to monitor the situation, but we do not expect any further impacts for this incident.

    The team is working on a strategy to ensure this level of impact cannot reoccur in the future.

  • Update
    Update
    Our vendor is continuing working on fixes. Tiles, marketing site, and all other systems other than our client dashboard have been restored.
  • Update
    Update
    Our upstream vendor is continuing to implement a fix after identifying the cause as a power outage and subsequent cooling failure. We continue to monitor and mitigate to the extent possible within our systems. Due to unexpected points of failure, some Stamen Map Tiles and other tiles are affected. Our primary systems remain online and unaffected.
  • Update
    Update

    The dashboard remains unavailable due to the upstream issue.

    We continue to monitor with our upstream provider, and we will provide updates as they are available.

  • Identified
    Identified

    Our client dashboard is currently unavailable due to an upstream outage with our cloud provider.

    We will provide updates as we receive them.