Stadia Maps, Inc. - Degraded Performance in North America – Incident details

Degraded Performance in North America

Resolved
Degraded performance
Started 20 days agoLasted 2 days

Affected

Maps

Degraded performance from 11:30 AM to 4:32 PM, Operational from 4:32 PM to 6:12 AM

Raster Map Tile API

Degraded performance from 11:30 AM to 4:32 PM, Operational from 4:32 PM to 6:12 AM

Vector Map Tile API

Degraded performance from 11:30 AM to 4:32 PM, Operational from 4:32 PM to 6:12 AM

Static Maps API

Degraded performance from 11:30 AM to 4:32 PM, Operational from 4:32 PM to 6:12 AM

Map Styles

Degraded performance from 11:30 AM to 4:32 PM, Operational from 4:32 PM to 6:12 AM

Satellite Map Styles (Raster Tile and Static Map APIs)

Degraded performance from 11:30 AM to 4:32 PM, Operational from 4:32 PM to 6:12 AM

Updates
  • Resolved
    Resolved

    After monitoring, performance remains within expectations.

    This incident has been resolved.

  • Monitoring
    Monitoring

    Our cloud provider has migrated the relevant infrastructure, and we are seeing full recovery of performance.

    We will continue monitoring, but we do not expect any further impacts of this event.

  • Update
    Update

    Our cloud provider has identified the cause of the latency, escalated it to the appropriate engineers, and they are working on a solution.

    We will continue to provide updates as we have them.

  • Identified
    Identified

    We have investigated and identified an on-going networking and performance issue impacting our services in North America. We are not observing errors or request failures, but are seeing degraded performance on approximately 5% of requests across our services.

    We have reported the issue to the responsible service provider, and we will share further updates as they become available.