Stadia Maps, Inc. - Degraded Performance in North America – Incident details

Degraded Performance in North America

Resolved
Degraded performance
Started 9 days agoLasted 1 day

Affected

Maps

Degraded performance from 12:15 AM to 12:16 AM, Operational from 12:16 AM to 7:41 AM

Raster Map Tile API

Degraded performance from 12:15 AM to 12:16 AM, Operational from 12:16 AM to 7:41 AM

Vector Map Tile API

Degraded performance from 12:15 AM to 12:16 AM, Operational from 12:16 AM to 7:41 AM

Static Maps API

Degraded performance from 12:15 AM to 12:16 AM, Operational from 12:16 AM to 7:41 AM

Map Styles

Degraded performance from 12:15 AM to 12:16 AM, Operational from 12:16 AM to 7:41 AM

Satellite Map Styles (Raster Tile and Static Map APIs)

Degraded performance from 12:15 AM to 12:16 AM, Operational from 12:16 AM to 7:41 AM

Updates
  • Resolved
    Resolved

    Performance remains as expected.

    This incident has been resolved. We will continue working with our cloud provider to ensure this does not reoccur.

  • Update
    Update

    Our cloud provider has implemented a fix, and we have moved traffic back to normal regional operations.

    We do not expect further impact of this issue, but we will continue to monitor to ensure no further impact.

  • Monitoring
    Monitoring

    After continue discussion with our cloud provider, we have opted to fail-over most North American traffic to our EU-based datacenters while we continue to wait for an upstream resolution.

    We expect North American performance to return to close to baseline with some additional latency. The worst case performance should be significantly lower.

    We will continue monitoring and discussing with our cloud provider.

  • Update
    Update

    Our infrastructure provider is continuing to work on this issue.

    We have not yet been provided a resolution timeline, but we are actively investigating alternative solutions to prevent future reoccurrence of this issue.

    Thank you for your patience. If you have any questions or concerns, please do not hesitate to reach out to support.

  • Identified
    Identified
    We have investigated and identified an on-going networking and performance issue impacting our services in North America. We are not observing any errors or request failures, but we are seeing degraded performance on approximately 5% of requests across our services. We have reported the issue to the responsible service provider, and we will share further updates as they become available.