Stadia Maps, Inc. - Elevated Static Maps Errors – Incident details

Elevated Static Maps Errors

Resolved
Partial outage 60 %
Started 13 days agoLasted about 1 hour

Affected

Maps

Partial outage from 1:42 PM to 2:10 PM, Degraded performance from 2:10 PM to 2:43 PM

Static Maps API

Partial outage from 1:42 PM to 2:10 PM, Degraded performance from 2:10 PM to 2:43 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved.

    We have identified the cause to be a latent bug in a recent package upgrade. We have rolled this back, and will further investigate in the upcoming week.

  • Monitoring
    Monitoring

    We implemented a emergency fix and are currently monitoring the result.

    We are continuing to work on identifying any root causes and implementing permanent fixes.

  • Investigating
    Investigating

    We have identified elevated errors with static maps. We are currently investigating this incident.