Stadia Maps, Inc. - Elevated Static Map Errors – Incident details

Elevated Static Map Errors

Resolved
Partial outage 15 %
Started 25 days agoLasted 1 day

Affected

Maps

Partial outage from 8:30 AM to 11:41 AM, Degraded performance from 11:41 AM to 2:33 PM

Static Maps API

Partial outage from 8:30 AM to 11:41 AM, Degraded performance from 11:41 AM to 2:33 PM

Updates
  • Resolved
    Resolved

    The impact has been entirely mitigated. This incident has been resolved.

  • Monitoring
    Monitoring

    We have implemented further mitigations, and we are observing complete restoration of services. We will continue monitoring for any continued impact.

  • Investigating
    Investigating

    We are aware of sporadic, elevated errors and timeouts in the Static Maps API.

    The root cause is a coordinated DDOS-style attack. We have implemented multiple mitigations, and observed corresponding improvements in the impact, but we have yet to fully contain the attack due to its complexity.

    We are actively working to contain it, and expect to see improvements within the next hour.